Если у тебя проблема, попробуй ее решить. Не можешь ее решить, тогда не делай из этого проблемы

Linux: Ошибка libzip при сборке PHP 8 под CentOS 7

На днях, при сборке PHP 8 под CentOS 7 столкнулся вот с такой ошибкой:


checking for zip archive read/write support... yes
checking for libzip >= 0.11 libzip != 1.3.1 libzip != 1.7.0... no
configure: error: Package requirements (libzip >= 0.11 libzip != 1.3.1 libzip != 1.7.0) were not met:

Requested 'libzip >= 0.11' but version of libzip is 0.10.1

Победил ее практически стандартным способом с небольшой настройкой cmake (указал префикс установки, чтобы заменить используемую устаревшую библиотеку по умолчанию).

  • Скачал свежие исходники библиотеки libzip, с официального сайта https://libzip.org/download/.
  • Распаковал их и запустил следующие команды:


mkdir build
cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr
make
make test
make install

Дальше сборка PHP 8 прошла без каких либо приключений.

Ответить
Обязательные поля помечены *